قالب امگا 4

شما اینجا هستید

3 پست / 0 جدید
آخرین ارسال

وضعیت: آفلاین
  • نسخه دروپال: 30.00
  • تعداد ارسال: ۱۱۳
  • تاریخ عضویت: ۲۰۱۱/۱۲/۰۳
  • آخرین حضور: ۲۰۱۵/۱۰/۲۶
  • سمت: کاربر عضو
  • موقعیت: قزوین

سلام
من با امگا 4 شروع به کار کردم و یک قالب برای سایتم درست کردم ولی نتونستم با sass کار کنم یعنی کدهای sass رو وارد میکنم اما نمیدونم چطوری باید کامپایل بشن.


وضعیت: آفلاین
  • تعداد ارسال: ۳۵۵
  • تاریخ عضویت: ۲۰۱۰/۰۱/۲۵
  • آخرین حضور: ۲۰۱۵/۰۷/۰۳
  • سمت: کاربر عضو
  • موقعیت: نامشخص

اول از همه نیاز هست که Ruby و RVM ( Ruby Version Manager) رو نصب کنی

curl -L https://get.rvm.io | bash -s stable --ruby

بعد از این باید RVM رو استارت کنی (البته مسیر نصب ات رو باید تصحیح کنی)

source /home/ubuntu/.rvm/scripts/rvm

حالا ما نیاز داریم که نسخه جدیدتر روبی 1.9.3 رو نصب کنیم

rvm install 1.9.3

شما می تونی با دستور rvm list کل لیست ورژن های روبی رو ببین و انی که ستاره داره در حال حاضر استفاده میشه
با دستور rvm use [version] می تونی ورژن اش عوض اش کنی .

تست اینکه RVM به درستی کار میکنه

type rvm | head -n 1

حالا باید به مسیر پوشه تم امگات بری sites/all/themes/your_theme_folder دستور زیر رو اجرا کنی

rvm requirements

اگر همه چی درست باشه باید این پیغام رو بده Requirements installation successful

حالا ما نیاز داریم که bundle رو نصب کنیم ، bundle تمام ابزار هایی مثل compass, sass, toolkit و.. رو برامون نصب میکنه

bundle install

وقتی که این پیغام رو دیدید bundle is complete! همه چی به خوبی نصب نشده ، شما می تونی از ساس استفاده کنی.


وضعیت: آفلاین
  • نسخه دروپال: 30.00
  • تعداد ارسال: ۱۱۳
  • تاریخ عضویت: ۲۰۱۱/۱۲/۰۳
  • آخرین حضور: ۲۰۱۵/۱۰/۲۶
  • سمت: کاربر عضو
  • موقعیت: قزوین

سپاس از پاسختون.
اگر بخواهیم روی هاست نصب کنیم چطوری هستش؟